2011年05月03日

gemでインストールしたのにエラーとなる場合は

gemでインストールしたのにエラーとなる場合は
rubygemsをrequireしているか確認し、requireしていなければrequireする

requireする方法:

1、ファイルの先頭に書く

#!ruby -Ku
require 'rubygems'
require 'Qt4'

2、ruby コマンドに "-rubygems" をつけてスクリプトを実行

>ruby -rubygems filename.rb

3、環境変数に追加

変数名「RUBYOPT」を新規作成し、変数値「-rubygems」を追加
タグ:ruby
posted by sige at 00:58| Comment(2) | ruby | 更新情報をチェックする
この記事へのコメント

尺八してもらったけどありゃたまんねーな!!
ジュパジュパ凄い音させながら吸いつかれて、30秒で発射しちまった(笑)
しかもオレ、女にお任せして寝てただけなのに5マソも貰った件wwww
http://azna7iy.jp.takaoka.mobi/
Posted by 吸引力の変わらないただひとつの… at 2011年07月30日 12:15
第36回 エリザベス女王杯 2011 競馬予想は最新情報がモノを言う!ライブで得る一般には漏れない情報と独自のデータ予想で勝ち馬ゲット!緻密なデータで今回は勝ちにこだわります!
Posted by 第36回 エリザベス女王杯 2011 at 2011年11月03日 20:54
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント:

×

この広告は1年以上新しい記事の投稿がないブログに表示されております。